J> I have many HP Z420 systems I have tried this with.  They can all
   J> install ANY other OS I have tried via USB in Legacy mode
   J> (Non-UEFI).  I have built the USB with Rufus, Win32diskImager, dd
   J> mode inside of CentOS as well as through Windows, UniversalUSB
   J> installer, Unetbootin, Xboot, Etcher, and several other not
   J> listed here.  It's not the USB drive, as I've used SEVERAL
   J> different sticks.  I have re-used these sticks after trying
   J> Qlustar, to install other OS's, and they still work perfectly
   J> fine, and can load the vfat module when installing.  Currently,
   J> I've built a Rocks7 cluster from these various USB sticks with NO
   J> issues. Hell, I've even tried to restore the thumb as a HDD from
   J> the qlustar image inside of CentOS to no luck.

   J> The error is simple: run/initramfs/live unknown filesystem type
   J> vfat

   J> I've also tried to build a CD/DVD to boot from, and I run into
   J> the exact same issue: unknown filesystem type vfat.

Yes, booting the same thing from a different media won't help.

So, I wanted to update everyone on this. The current state of affairs on my three Skylake HP desktops that I’ve been trying to use as cluster nodes is as follows:

At the end of my rope, I finally tried booting from a CD-R. The first time I tried burning it, the disc was rife with errors and the system wouldn’t boot properly after installation. The second time seemed to work and I was able to complete head node installation, but I couldn’t get compute nodes to bootstrap correctly. I may try this again tonight, because I found a way to boot from USB:

I tried installing Bright not long after this (which you all can try now if you have 8 compute nodes or fewer: https://community.brightcomputing.com/feed/easy8-users-getting-started). I started out with exactly the same problem as the Qlustar installer. I beat my head against the problem some more and was finally able to get all the way through the installation process by using the YUMI utility ( https://www.pendrivelinux.com/yumi-multiboot-usb-creator/ ) and telling it to place the boot image in “partition 4” on the USB as listed in the imaging options. Why this is a thing that matters, I have no idea. Maybe someone else has a clue as to why starting the installer from inside the YUMI boot environment and choosing this extra partition option seems to work where no other option does.

So, Jeremy, I think our problems are related, but not identical. I would be willing to bet, though, that something about what HP does with desktop (or workstation) BIOSes causes this problem. I’ve scoured the internet for search terms like “HP cannot boot Linux” but while a number of people seem to have this issue or something related to it, no one seems to have solutions. https://h30434.www3.hp.com/t5/Notebook-Boot-and-Lockup/Cannot-boot-from-usb-flash-drive-to-install-linux/td-p/6251826

Really, really strange stuff. But — give YUMI a try and please report back whether it worked for you.